Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Jul 2005
    Posts
    2
    Thanked: 0

    Default Weishi DE with a bit of rust

    I've got a Weishi DE razor that I use, and I've been really happy with it. But recently I've noticed a little bit of rust creeping around and the mechanism to open the top is getting a little stiff. Any suggestions for how to clean and loosen these two part? I thought of WD-40 but held-off on that in case someone has better suggestions..

    TIA

  2. #2
    Senior Member oldfat1's Avatar
    Join Date
    Aug 2008
    Location
    North Carolina
    Posts
    145
    Thanked: 51

    Default

    WD-40 can cause a reaction on your skin. Clean it with Scrubbing Bubbles and a tooth brush. If you want to oil it use Mineral Oil.

  3. #3
    Junior Member
    Join Date
    Jul 2005
    Posts
    2
    Thanked: 0

    Default

    Yeah, thats what I was thinking about with the WD-40. I'll have to go grab some scrubbing bubbles..thanks for the help

  4. #4
    The Assyrian Obie's Avatar
    Join Date
    Mar 2009
    Location
    Milwaukee, WI
    Posts
    10,198
    Thanked: 2729

    Default Weishi DE . . .

    Gentlemen,

    Yes, Scrubbing Bubble and mineral oil are fine recommendations. Good thinking, Ken.

    Regards,

    Obie

  5. #5
    Excited Member AxelH's Avatar
    Join Date
    Apr 2008
    Location
    My Own Hell Hole, Minnesota
    Posts
    619
    Thanked: 73

    Question

    I've got a little browning/rust forming inside mine, luckily no problems with the opening action. I thought MAAS paste would remove it, if it became a concern. Also a little tuf-glide or similar protectant, beyond the MAAS, as a standard corrosion resistance counter-measure?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •